Dodge Dart Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter · #1 ·
ok so I don't know if any of you had this problem or not, but at higher boost when the valve would open I would get the woosh of the plate followed by the sound of it coming through the intake. it was almost like 2 bov's I took off the plate and couldn't figure how it was happening other than the holes being too small and the excess pressure pushing past the o rings.. any way I decided to open up the holes.. I went to 3/8. and needless to say this cured the problem and made the bov louder slightly. very easy to do just drill the holes out and make sure there isn't any metal left behind..


 

·
Registered
Joined
·
2 Posts
Did you have the stock air intake or an aftermarket intake? I just threw on a short ram and the way you described it, pressure pushing past the o ring, seems like what im currently experiencing. Only started today, when I put on the new intake
 

·
Registered
Joined
·
173 Posts
so my dealer told me this wasn't good for my car and they took it off at the dealer bc I have a warranty for so many miles.
And what was their reasoning for this? I've had this part on my car for 11k miles now without any issue. I've been working on cars for 20 years and never heard of anything remotely bad being caused by a diverter plate or BOV (unless it was stuck and not allowing the boost pressure out). I'd be upset that the dealer was taking parts off my car too. Warranty or not I don't see how this part can cause problems. I think your dealership might be feeding you a line of crap honestly.
 

·
Registered
Joined
·
28 Posts
did you drill all 6 holes or just 3... i was thinkin about doin it myself
 

·
Registered
Joined
·
4 Posts
First post here as a member...

I had my 1.4l 14 days before installing my plate. has anyone noticed a slight sputter from the exhaust once and a while or what sounds as an air studder up front both on exceleration (1st or 2nd gear) at maybe 3 grand or a little more after installing this?

Happened to me today (studder in the front) and the the sputter in the back 2 days ago both on boost. Never had it before adding the mod.

Could i have a leak at the plate maybe? I put it on tight when the engine was still pretty warm. not sure if that would create a small gap between the plate and housing or not.
 

·
Registered
Joined
·
12 Posts
after installing my intake and IC piping i noticed this backfiring sound. i went and drilled out mine just like perry25 has stated and it solved issue. i didnt go to 3/8 i only used 11/32 drill bit but it did the job.
 
1 - 15 of 15 Posts
Top