Dodge Dart Forums banner
1 - 20 of 111 Posts

·
ProFRESHional
Joined
·
210 Posts
Discussion Starter · #1 ·
Remove the cover off the engine and take a look at the charge pipe on the Driver's side. You should see the MAF sensor and the 3/8" vacuum line just prior to it. If you follow this line you will see that it goes to a Tee. One side goes to the intake manifold (I believe) and the other goes to the intake just prior to the turbo. There is NO check valve which means that this a direct boost leak. This is the reason for laggy boost and boost dropping off on the top end. I removed the hose on the charge pipe (driver's side). I place a rubber/plastic cap on the tube then placed the hose back on it. This effectively blocked off the flow. Now I have more TQ down low with a quicker spool and more HP up top with no boost leaks. The car is enjoyably to drive.
 

·
Registered
Joined
·
314 Posts
Yeahhhh I've seen this Mod elsewhere, not sold on it yet though...just don't seem right for some reason.
 

·
ProFRESHional
Joined
·
210 Posts
Discussion Starter · #4 ·
Yeahhhh I've seen this Mod elsewhere, not sold on it yet though...just don't seem right for some reason.
I agree BUT my dad is a car mechanic of 40+ years so I'm going to run it by him and see if I can't get more insight. I'll let everyone know as soon as I find out.
 

·
ProFRESHional
Joined
·
210 Posts
Discussion Starter · #5 ·
Well we finally got around to doing this and there is ZERO boost lag...it's like a whole new car. Highly recommend it and it takes 2 min
 

·
Registered
Joined
·
314 Posts
Well we finally got around to doing this and there is ZERO boost lag...it's like a whole new car. Highly recommend it and it takes 2 min
OK, you've inspired me! LOL Time to get this mod done!
 

·
Registered
Joined
·
19 Posts
I just removed the entire rubber hose and the plastic hose and capped the outlets with 3/8 caps and then secured them with clamps. didn't really notice a boost it power but too late to undo cuz i broke the plastic hose takin it off. tried to be careful but it was already brittle from heat and just crumbled on the ends. im sure if i wanted it replaced i could just get it from the dealer.. but no biggie.
 

·
Registered
Joined
·
26 Posts
I see some people have intakes on theirs, i just put a high flow filter, where can i find an intake for the car thats not 200 dollars? or if you made one yourself, what did you do for the sensors to avoid a check engine?

I just removed the entire rubber hose and the plastic hose and capped the outlets with 3/8 caps and then secured them with clamps. didn't really notice a boost it power but too late to undo cuz i broke the plastic hose takin it off. tried to be careful but it was already brittle from heat and just crumbled on the ends. im sure if i wanted it replaced i could just get it from the dealer.. but no biggie.
 

·
ProFRESHional
Joined
·
210 Posts
Discussion Starter · #13 ·
I see some people have intakes on theirs, i just put a high flow filter, where can i find an intake for the car thats not 200 dollars? or if you made one yourself, what did you do for the sensors to avoid a check engine?
the MAF is not on the air intake rather its further downline so putting on a filer causes no CELs whatsoever
 

·
ProFRESHional
Joined
·
210 Posts
Discussion Starter · #17 ·
I'm looking to do this mod, but where does this hose I'm capping off lead to? Seems like a strange fix, but the turbo lag is intense. Heck if it works..
Lol I honestly don't know but my dad is a certified mechanic and said it looks like a way Dodge uses as a "governor" almost...I have over 2k miles now and still no CELs
 
1 - 20 of 111 Posts
Top